Accueil › Installation

# Configuration de php

Deltacms nécessite php 7.2 ou une version supérieure, il fonctionne avec php 8. Les modules php nécessaires sont : mbstring, gd, exif, zip, xmlwriter et date, fileinfo, Phar (ces 3 derniers modules sont inclus à partir de php 7.4).

# Installation

  • Dézippez l'archive deltacms_vx.xx.xx.zip , vous obtenez un dossier deltacms_vx.xx.xx qui contient :

 

Transférez  ces 3 dossiers, core, module, site et ces fichiers à la racine de votre hébergement ou dans un répertoire de votre choix,

Installation

Le sélecteur de pays en haut à droite adapte les labels de cette page d'installation.

Langue d'administration : elle détermine tous les textes utilisés dans l'administration de votre site et le site exemple, vous pouvez choisir français ou anglais. Vous pouvez modifier ce réglage à tout moment dans la 'Gestion des langues'.

Langue originale du site : vous pouvez bien sûr rédiger votre site dans n'importe qu'elle langue, mais cette sélection détermine la langue d'origine pour la traduction automatique ainsi que les messages d'aide dans l'éditeur de texte utilisé pour les commentaires de blog et la vue principale de l'agenda. Vous avez le choix entre 16 langues européennes ou régionales, vous pouvez le modifier à tout moment dans la 'Gestion des langues'. Si vous ne trouvez pas votre langue choisissez 'Other language (?)'.

Après validation de cette page d'installation,  si la case 'Sans exemple de site' n'est pas cochée, un site d'exemple s'installe dans la langue choisie pour l'administration à l'exception de la page d'accueil qui est dans la langue originale du site. Il ne vous reste plus qu'à vous connecter avec le lien disposé dans le pied de page !

 

Gérer les cookies

Ce site utilise des cookies nécessaires à son fonctionnement, ils permettent de fluidifier son fonctionnement par exemple en mémorisant les données de connexion, la langue que vous avez choisie ou la validation de ce message.


Consulter les mentions légales